正點財經首頁     加入收藏
指標首頁 通達信指標 同花順指標 大智慧指標 飛狐指標 指標教程 指標實戰 指標百科 股市學院
指標源碼搜索: 熱詞:買賣  黑馬  K線  牛股  量能  波段  頂底  抄底  成本  逃頂  MACD  漲停  換手率
你的位置: > 正點財經 > 炒股指標公式 > 通達信指標公式 > 正文

通達信經典MACD指標公式

通達信指標公式源碼概況:
  • 指標類別: 通達信指標公式
  • 授權方式: 免費版
  • 指標評級: ★★★★★
  • 指標分類: 趨勢
  • 畫線方法: 副圖
  • 日期:2023-03-13 來源:互聯網
通達信指標公式源碼介紹:

通達信經典MACD指標公式:包含未來函數:DRAWLINE

A:=VOL*C;
B:=SUM(A,1)/SUM(VOL,1);
B1:=EMA(B,17); 資金:=(B-B1)*100/B; DIFF:EMA(資金,12)-EMA(資金,26);
DEA: EMA(DIFF,9); M: 2*(DIFF-DEA), COLORSTICK;
{紅色立柱}
STICKLINE(M>=REF(M,1)AND M>0,0,M,2.2,0),COLOR000088;
STICKLINE(M>=REF(M,1)AND M>0,0,M,1.5,0),COLOR0000AA;
STICKLINE(M>=REF(M,1)AND M>0,0,M,0.5,0),COLOR0000CC;
STICKLINE(M>=REF(M,1)AND M>0,0,M,0.1,0),COLOR0000EE;
{金黃色立柱}
STICKLINE(M<REF(M,1)AND M>0,0,M,2.2,0),COLOR338888;
STICKLINE(M<REF(M,1)AND M>0,0,M,1.3,0),COLOR33AAAA;
STICKLINE(M<REF(M,1)AND M>0,0,M,0.9,0),COLOR33CCCC;
STICKLINE(M<REF(M,1)AND M>0,0,M,0.1,0),COLOR33EEEE;
{粉紅立柱}
STICKLINE(M>REF(M,1)AND M<0,0,M,2.2,0),COLORCC00CC;
STICKLINE(M>REF(M,1)AND M<0,0,M,1.1,0),COLOREE00EE;
STICKLINE(M>REF(M,1)AND M<0,0,M,0.1,0)COLORFF00FF;
{綠色立柱}
STICKLINE(M<=REF(M,1)AND M<0,0,M,2.2,0),COLOR009900;
STICKLINE(M<=REF(M,1)AND M<0,0,M,1.5,0),COLOR00BB00;
STICKLINE(M<=REF(M,1)AND M<0,0,M,1.1,0),COLOR00DD00;
STICKLINE(M<=REF(M,1)AND M<0,0,M,0.1,0),COLOR00FF00;
IF(DIFF<0,DIFF,0),COLORRED,LINETHICK2;
IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK2;
IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK2;
IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;
低金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
{金黃色立柱}
STICKLINE(低金叉,-4,-2,2.5,0),COLOR338888;
STICKLINE(低金叉,-4,-2,1.5,0),COLOR33AAAA;
STICKLINE(低金叉,-4,-2,0.9,0),COLOR33CCCC;
STICKLINE(低金叉,-4,-2,0.1,0),COLOR33EEEE;
STICKLINE(低金叉,-0.4,-2,0.3,1),COLOREE00EE;
DRAWTEXT(低金叉,-3,' 低位金叉'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二金:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
{粉紅立柱}
STICKLINE(二金,0,-2.5,2,0),COLORCC00CC;
STICKLINE(二金,0,-2.5,1.5,0),COLOREE00EE;
STICKLINE(二金,0,-2.5,0.1,0)COLORFF00FF;
DRAWICON(二金,DEA*1.2,23) ;
DRAWTEXT(二金,-2,' 二次金叉'),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1)AND CROSS(DIFF,DEA);
{綠色立柱}
STICKLINE(底背,0,2.5,2.5,0),COLOR009900;
STICKLINE(底背,0,2.5,1.4,0),COLOR00BB00;
STICKLINE(底背,0,2.5,0.5,0),COLOR00DD00;
STICKLINE(底背,0,2.5,0.1,0),COLOR00FF00;
STICKLINE(底背,4.5,2.5,0.3,1),COLOR0000FF;
DRAWLINE(A1=0,DEA,底背,DEA,0),COLORRED,LINETHICK2;
DRAWTEXT(底背,2,' 底背離'),COLOR00FF00;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
頂背:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
{深 青色立柱}
{STICKLINE(頂背,2.5,4,3,0),COLORCC0000; }
STICKLINE(頂背,2.5,4,2.5,0),COLORFF4400;
STICKLINE(頂背,2.5,4,1.5,0),COLORFF8800;
STICKLINE(頂背,2.5,4,0.2,0),COLORFFCC00;
STICKLINE(頂背,0.4,2.5,0,0),COLORFFFFFF;

通達信經典MACD指標公式實例圖解:

通達信經典MACD指標公式

通達信經典MACD指標公式

  • 風云榜
  • 總點擊榜
  • 最新指標
月點擊榜指標公式
更多指標百科
關于我們 | 商務合作 | 聯系投稿 | 聯系刪稿 | 合作伙伴 | 法律聲明 | 網站地圖
欧人与动牲交a欧美精品