正點財經首頁     加入收藏
指標首頁 通達信指標 同花順指標 大智慧指標 飛狐指標 指標教程 指標實戰 指標百科 股市學院
指標源碼搜索: 熱詞:買賣  黑馬  K線  牛股  量能  波段  頂底  抄底  成本  逃頂  MACD  漲停  換手率
你的位置: > 正點財經 > 炒股指標公式 > 通達信指標公式 > 正文

通達信炒股不要太簡單5主圖指標公式

通達信指標公式源碼概況:
  • 指標類別: 通達信指標公式
  • 授權方式: 免費版
  • 指標評級: ★★★★★
  • 指標分類: 均線
  • 畫線方法: 主圖
  • 日期:2023-11-22 來源:互聯網
通達信指標公式源碼介紹:

通達信炒股不要太簡單5主圖指標公式:

STICKLINE(1,H,L,6,0),COLORBLACK;
周期1:SUMBARS(VOL,CAPITAL/4),COLORWHITE,NODRAW;
周期2:SUMBARS(VOL,CAPITAL/2),COLORYELLOW,NODRAW;
周期3:SUMBARS(VOL,CAPITAL),COLORRED,NODRAW;
轉向價格幅度:HHV(ABS(C/REF(C,1)*100-100),(周期1+周期2+周期3)/3),COLORGREEN,NODRAW;
之轉向線:=ZIG(3,轉向價格幅度);
上一次波峰值:=PEAK(3,轉向價格幅度,1);
上一次波谷值:=TROUGH(3,轉向價格幅度,1);
上一次波峰位置:=PEAKBARS(3,轉向價格幅度,1);
上一次波谷位置:=TROUGHBARS(3,轉向價格幅度,1);
BG:=CONST(上一次波谷位置);
BF:=CONST(上一次波峰位置);
目前所處趨勢:=IF(上一次波谷位置<上一次波峰位置,1,0);
轉向達成:=IF(目前所處趨勢=1,上一次波谷值*(1+轉向價格幅度/100),上一次波峰值*(1-轉向價格幅度/100)),COLORRED,NODRAW;
向上達成:=CONST(EXIST(C>轉向達成,BG));
向下達成:=CONST(EXIST(C<轉向達成,BF));
預判價:IF(之轉向線>REF(之轉向線,1) AND CURRBARSCOUNT<=MIN(BF,BG) AND 向上達成<1,上一次波谷值*(1+轉向價格幅度*0.382/100),
IF(之轉向線<REF(之轉向線,1) AND CURRBARSCOUNT<=MIN(BF,BG) AND 向下達成<1,上一次波峰值*(1-轉向價格幅度*0.382/100),DRAWNULL)),COLORMAGENTA,DOTLINE;
糾錯價:IF(之轉向線>REF(之轉向線,1) AND CURRBARSCOUNT<=MIN(BF,BG) AND 向上達成<1,上一次波谷值,
IF(之轉向線<REF(之轉向線,1) AND CURRBARSCOUNT<=MIN(BF,BG) AND 向下達成<1,上一次波峰值,DRAWNULL)),COLORLIBLUE,DOTLINE;
確認價:IF(之轉向線>REF(之轉向線,1) AND CURRBARSCOUNT<=MIN(BF,BG) AND 向上達成<1,轉向達成,
IF(之轉向線<REF(之轉向線,1) AND CURRBARSCOUNT<=MIN(BF,BG) AND 向下達成<1,轉向達成,DRAWNULL)),COLORRED,DOTLINE;
動態高點:IF(CURRBARSCOUNT<=MAX(BG,BF),REF(HHV(H,IF(周期1<2,2,周期1)),1),DRAWNULL),COLORBLUE,DOTLINE;
動態低點:IF(CURRBARSCOUNT<=MAX(BG,BF),REF(LLV(L,IF(周期1<2,2,周期1)),1),DRAWNULL),COLORBLUE,DOTLINE;
近期成本均線:=MA(C,周期1),COLORGREEN;
中期成本均線:=MA(C,周期2),COLORWHITE;
長期成本均線:=MA(C,周期3),COLORYELLOW;
ZQ1:=CONST(周期1);
ZQ2:=CONST(周期2);
ZQ3:=CONST(周期3);
STICKLINE(之轉向線>REF(之轉向線,1),H,L,0,1),COLORLIRED;
STICKLINE(之轉向線>REF(之轉向線,1),O,C,2,1),COLORLIRED;
STICKLINE(之轉向線>REF(之轉向線,1) AND C>O,O,C,2,0),COLORLIRED;
STICKLINE(之轉向線<REF(之轉向線,1),H,L,0,1),COLORCYAN;
STICKLINE(之轉向線<REF(之轉向線,1),O,C,2,1),COLORCYAN;
STICKLINE(之轉向線<REF(之轉向線,1) AND C<O,O,C,2,0),COLORCYAN;
STICKLINE(CURRBARSCOUNT<=BG AND 向上達成<1,H,L,0,0),COLORYELLOW;
STICKLINE(CURRBARSCOUNT<=BG AND 向上達成<1 AND C>O,O,C,2,0),COLORYELLOW;
STICKLINE(CURRBARSCOUNT<=BG AND 向上達成<1 AND C<O,O,C,2,1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT<=BG AND 向上達成<1 AND C>預判價,H,L,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT<=BG AND 向上達成<1 AND C>O AND C>預判價,O,C,2,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT<=BG AND 向上達成<1 AND C<O AND C>預判價,O,C,2,1),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT<=BF AND 向下達成<1,H,L,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT<=BF AND 向下達成<1 AND C>O,O,C,2,1),COLORGREEN;
STICKLINE(CURRBARSCOUNT<=BF AND 向下達成<1 AND C<O,O,C,2,0),COLORGREEN;
STICKLINE(C>近期成本均線 AND 近期成本均線>中期成本均線 AND 中期成本均線>長期成本均線,MAX(O,C),(O+C)/2,2.3,0),COLORRED;
STICKLINE(C<近期成本均線 AND 近期成本均線<中期成本均線 AND 中期成本均線<長期成本均線,MIN(O,C),(O+C)/2,2.3,0),COLORBLUE;
均線1:MA(C,ZQ1),COLORWHITE;
均線2:MA(C,ZQ2),COLORYELLOW;
均線3:MA(C,ZQ3),COLORRED,DOTLINE;
DRAWTEXT(ISLASTBAR AND 之轉向線>REF(之轉向線,1) AND 向上達成<1,轉向達成,CON2STR(轉向達成,2)),COLORRED;
DRAWTEXT(ISLASTBAR AND 之轉向線<REF(之轉向線,1) AND 向下達成<1,轉向達成,CON2STR(轉向達成,2)),COLORRED;
DRAWTEXT(ISLASTBAR AND 之轉向線>REF(之轉向線,1) AND 向上達成<1,預判價,CON2STR(預判價,2)),COLORWHITE;
DRAWTEXT(ISLASTBAR AND 之轉向線<REF(之轉向線,1) AND 向下達成<1,預判價,CON2STR(預判價,2)),COLORWHITE;
DRAWTEXT(ISLASTBAR AND 之轉向線>REF(之轉向線,1) AND 向上達成<1,糾錯價,CON2STR(糾錯價,2)),COLORLIBLUE;
DRAWTEXT(ISLASTBAR AND 之轉向線<REF(之轉向線,1) AND 向下達成<1,糾錯價,CON2STR(糾錯價,2)),COLORLIBLUE;
DRAWTEXT_FIX(1,0.3,0.5,0,'用到未來函數,信號會漂移,僅供學習交流,不作操作建議,底下有底,謹慎抄底。!不讀源碼者禁用。。。。!'),COLORMAGENTA;
DRAWICON(之轉向線>REF(之轉向線,1) AND CROSS(C,預判價),L*0.97,7);{不喜可刪}
DRAWICON(之轉向線<REF(之轉向線,1) AND CROSS(預判價,C),H*1.02,8);{不喜可刪};

通達信炒股不要太簡單5主圖指標公式實例圖解:

通達信炒股不要太簡單5主圖指標公式

通達信炒股不要太簡單5主圖指標公式

  • 風云榜
  • 總點擊榜
  • 最新指標
月點擊榜指標公式
更多指標百科
關于我們 | 商務合作 | 聯系投稿 | 聯系刪稿 | 合作伙伴 | 法律聲明 | 網站地圖
欧人与动牲交a欧美精品